Skip to main content

Command Palette

Search for a command to run...

MOT Error Messages

Published
•4 min read•View as Markdown

MOT Error Messages

Errors may be caused by a variety of scenarios. All errors are logged in the database server log file. In addition, user-related errors are returned to the user as part of the response to the query, transaction or stored procedure execution or to database administration action.

  • Errors reported in the Server log include – Function, Entity, Context, Error message, Error description and Severity.

  • Errors reported to users are translated into standard PostgreSQL error codes and may consist of an MOT-specific message and description.

The following lists the error messages, error descriptions and error codes. The error code is actually an internal code and not logged or returned to users.

Errors Written the Log File

All errors are logged in the database server log file. The following lists the errors that are written to the database server log file and are not returned to the user. The log is located in the data folder and named postgresql-DATE-TIME.log.

Table 1 Errors Written Only to the Log File

Message in the LogError Internal Code
Error code denoting successMOT_NO_ERROR 0
Out of memoryMOT_ERROR_OOM 1
Invalid configurationMOT_ERROR_INVALID_CFG 2
Invalid argument passed to functionMOT_ERROR_INVALID_ARG 3
System call failedMOT_ERROR_SYSTEM_FAILURE 4
Resource limit reachedMOT_ERROR_RESOURCE_LIMIT 5
Internal logic errorMOT_ERROR_INTERNAL 6
Resource unavailableMOT_ERROR_RESOURCE_UNAVAILABLE 7
Unique violationMOT_ERROR_UNIQUE_VIOLATION 8
Invalid memory allocation sizeMOT_ERROR_INVALID_MEMORY_SIZE 9
Index out of rangeMOT_ERROR_INDEX_OUT_OF_RANGE 10
Error code unknownMOT_ERROR_INVALID_STATE 11

Errors Returned to the User

The following lists the errors that are written to the database server log file and are returned to the user.

MOT returns PG standard error codes to the envelope using a Return Code (RC). Some RCs cause the generation of an error message to the user who is interacting with the database.

The PG code (described below) is returned internally by MOT to the database envelope, which reacts to it according to standard PG behavior.

NOTE: %s, %u and %lu in the message are replaced by relevant error information, such as query, table name or another information.

  • %s – String

  • %u – Number

  • %lu – Number

Table 2 Errors Returned to the User and Logged to the Log File

Short and Long Description Returned to the UserPG CodeInternal Error Code
Success.ERRCODE_SUCCESSFUL_COMPLETIONCOMPLETIONRC_OK = 0
FailureERRCODE_FDW_ERRORRC_ERROR = 1
Unknown error has occurred.ERRCODE_FDW_ERRORRC_ABORT
Column definition of %s is not supported.ERRCODE_INVALID_COLUMN_DEFINITIONRC_UNSUPPORTED_COL_TYPE
Column definition of %s is not supported.ERRCODE_INVALID_COLUMN_DEFINITIONRC_UNSUPPORTED_COL_TYPE_ARR
Column size %d exceeds max tuple size %u.ERRCODE_FEATURE_NOT_SUPPORTEDRC_EXCEEDS_MAX_ROW_SIZE
Column name %s exceeds max name size %u.ERRCODE_INVALID_COLUMN_DEFINITIONRC_COL_NAME_EXCEEDS_MAX_SIZE
Column size %d exceeds max size %u.ERRCODE_INVALID_COLUMN_DEFINITIONRC_COL_SIZE_INVLALID
Cannot create table.ERRCODE_FEATURE_NOT_SUPPORTEDRC_TABLE_EXCEEDS_MAX_DECLARED_COLS
Cannot create index.ERRCODE_FDW_KEY_SIZE_EXCEEDS_MAX_ALLOWEDRC_INDEX_EXCEEDS_MAX_SIZE
Cannot create index.ERRCODE_FDW_TOO_MANY_INDEXESRC_TABLE_EXCEEDS_MAX_INDEXES
Cannot execute statement.ERRCODE_FDW_TOO_MANY_DDL_CHANGES_IN_TRANSACTION_NOT_ALLOWEDRC_TXN_EXCEEDS_MAX_DDLS
Unique constraint violationERRCODE_UNIQUE_VIOLATIONRC_UNIQUE_VIOLATION
Table \"%s\" does not exist.ERRCODE_UNDEFINED_TABLERC_TABLE_NOT_FOUND
Index \"%s\" does not exist.ERRCODE_UNDEFINED_TABLERC_INDEX_NOT_FOUND
Unknown error has occurred.ERRCODE_FDW_ERRORRC_LOCAL_ROW_FOUND
Unknown error has occurred.ERRCODE_FDW_ERRORRC_LOCAL_ROW_NOT_FOUND
Unknown error has occurred.ERRCODE_FDW_ERRORRC_LOCAL_ROW_DELETED
Unknown error has occurred.ERRCODE_FDW_ERRORRC_INSERT_ON_EXIST
Unknown error has occurred.ERRCODE_FDW_ERRORRC_INDEX_RETRY_INSERT
Unknown error has occurred.ERRCODE_FDW_ERRORRC_INDEX_DELETE
Unknown error has occurred.ERRCODE_FDW_ERRORRC_LOCAL_ROW_NOT_VISIBLE
Memory is temporarily unavailable.ERRCODE_OUT_OF_LOGICAL_MEMORYRC_MEMORY_ALLOCATION_ERROR
Unknown error has occurred.ERRCODE_FDW_ERRORRC_ILLEGAL_ROW_STATE
Null constraint violated.ERRCODE_FDW_ERRORRC_NULL_VIOLATION
Critical error.ERRCODE_FDW_ERRORRC_PANIC
A checkpoint is in progress – cannot truncate table.ERRCODE_FDW_OPERATION_NOT_SUPPORTEDRC_NA
Unknown error has occurred.ERRCODE_FDW_ERRORRC_MAX_VALUE
<recovery message>-ERRCODE_CONFIG_FILE_ERROR
<recovery message>-ERRCODE_INVALID_TABLE_DEFINITION
Memory engine – Failed to perform commit prepared.-ERRCODE_INVALID_TRANSACTION_STATE
Invalid option <option name>-ERRCODE_FDW_INVALID_OPTION_NAME
Invalid memory allocation request size.-ERRCODE_INVALID_PARAMETER_VALUE
Memory is temporarily unavailable.-ERRCODE_OUT_OF_LOGICAL_MEMORY
Could not serialize access due to concurrent update.-ERRCODE_T_R_SERIALIZATION_FAILURE
Alter table operation is not supported for memory table.-ERRCODE_FDW_OPERATION_NOT_SUPPORTED
Allocation of table metadata failed.-ERRCODE_OUT_OF_MEMORY
Database with OID %u does not exist.-ERRCODE_UNDEFINED_DATABASE
Value exceeds maximum precision: %d.-ERRCODE_NUMERIC_VALUE_OUT_OF_RANGE
You have reached a maximum logical capacity %lu of allowed %lu.-ERRCODE_OUT_OF_LOGICAL_MEMORY

More from this blog

Untitled Publication

133 posts